Trying to upload picture to SG costume gallery

Use this forum to report bugs, request new features and bag on WeaponX because the history page isn't done yet.

Moderator: Moderators

Post Reply
User avatar
Darrk Waver
X Member
Posts: 1560
Joined: Sun Jan 23, 2005 1:00 am

Trying to upload picture to SG costume gallery

Post by Darrk Waver »

When I try to upload a picture to the SG costume gallery I get the following error:

Fatal error: Call to a member function on a non-object in /home/xsyn/public_html/common/gallery_functions.php on line 51

User avatar
Mr E-Man
Posts: 2801
Joined: Mon Aug 15, 2005 12:00 am
Location: South Jersey Coast of Freedom - near the Boardwalk!
Contact:

Post by Mr E-Man »

Frost is sick today, so it might be a while before he can take care of this.

Hang tight until he get a chance to fix it.
CoH: Mr E-Man~Energy Arc~IG-2112MD~Slayer Faith~Master TimeLord~Mr E-Being
CoV: Mr E-Villain~Dark Willow~Cold Satisfaction~Mr E-Mech~Mr E-Lectric
Image

User avatar
Frost
Site Admin
Posts: 6832
Joined: Thu Jan 27, 2005 1:00 am
Location: Syracuse, NY
Contact:

Post by Frost »

I'll look at it tomorrow...headed off to sleep now. Erg.

User avatar
Benoit
X Member
Posts: 7436
Joined: Sat Mar 02, 2002 1:00 am

Post by Benoit »

NO! DO IT NOW! :lol:

User avatar
Darrk Waver
X Member
Posts: 1560
Joined: Sun Jan 23, 2005 1:00 am

Post by Darrk Waver »

No worries. I hope you feel better soon.

User avatar
Frost
Site Admin
Posts: 6832
Joined: Thu Jan 27, 2005 1:00 am
Location: Syracuse, NY
Contact:

Post by Frost »

It's fixed. Honeslty, I have absolutly no idea how people were uploading anything to the gallery over the past week, but chromi was able to do it...hrm...

One of those big mysteries :)

User avatar
Darrk Waver
X Member
Posts: 1560
Joined: Sun Jan 23, 2005 1:00 am

Post by Darrk Waver »

I was able to upload the image, but when I did I got this:

(mysql): SELECT group_name, phpbb_user_group.group_id FROM phpbb_user_group, phpbb_groups WHERE phpbb_user_group.group_id = phpbb_groups.group_id AND phpbb_user_group.user_id = 260 ORDER BY group_name ASC
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
(mysql): SELECT group_name, phpbb_user_group.group_id FROM phpbb_user_group, phpbb_groups WHERE phpbb_user_group.group_id = phpbb_groups.group_id AND phpbb_user_group.user_id = 260 ORDER BY group_name ASC
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
(mysql): SELECT * FROM x_gallery_cat WHERE ( type = 2 OR user_id=260 ) AND id = 202
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
(mysql): INSERT INTO x_gallery_images (user_id, category_id, title, descr, upload_date, img_type) VALUES ( '260', 202, 'Bad to the Bone!', 'I ended up using red as the secondary color since it shows up better, but any color can be used. Upper body: Tight/Chest: Muscular / Warpaint Shoulder: Spiked Band 1 (black/white for members, black/yellow for captains) Chest Detail: Tribal Wings (with the same color used for both primary and secondary colors) Lower Body: Tight/Tights & Stripe 1 As with the CoH SG costume the gloves, belt, and boots are personal preference. ', '2006-03-12 10:17:43', 'jpg' )
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
(mysql): SELECT LAST_INSERT_ID()

Also, on the right side column, instead of seeing the different options/links I was seeing the code in back of the link similar to what I posted above.

Hope you're feeling better.

User avatar
DarkPowers
X Member
Posts: 3237
Joined: Sat Jan 29, 2005 1:00 am

Post by DarkPowers »

That was the error I spoke of too but when I went back to get exact wording, it worked. It seems to be happening randomly.

User avatar
Mr E-Man
Posts: 2801
Joined: Mon Aug 15, 2005 12:00 am
Location: South Jersey Coast of Freedom - near the Boardwalk!
Contact:

Post by Mr E-Man »

Uh Frost, when you go to the upload page, don't get embarassed, but all you code is showing! :roll:

Edit: These are some of the things showing --

(mysql): SELECT group_name, phpbb_user_group.group_id FROM phpbb_user_group, phpbb_groups WHERE phpbb_user_group.group_id = phpbb_groups.group_id AND phpbb_user_group.user_id = 408 ORDER BY group_name ASC


--------------------------------------------------------------------------------
(mysql): SELECT id FROM x_gallery_cat WHERE user_id = 408
--------------------------------------------------------------------------------


Edit Profile

--------------------------------------------------------------------------------
(mysql): SELECT group_name, phpbb_user_group.group_id FROM phpbb_user_group, phpbb_groups WHERE phpbb_user_group.group_id = phpbb_groups.group_id AND phpbb_user_group.user_id = 408 ORDER BY group_name ASC
--------------------------------------------------------------------------------
Edit Member Profile
--------------------------------------------------------------------------------
(mysql): SELECT group_name, phpbb_user_group.group_id FROM phpbb_user_group, phpbb_groups WHERE phpbb_user_group.group_id = phpbb_groups.group_id AND phpbb_user_group.user_id = 408 ORDER BY group_name ASC
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
(mysql): SELECT group_name, phpbb_user_group.group_id FROM phpbb_user_group, phpbb_groups WHERE phpbb_user_group.group_id = phpbb_groups.group_id AND phpbb_user_group.user_id = 408 ORDER BY group_name ASC
--------------------------------------------------------------------------------

News
Submit News


--------------------------------------------------------------------------------
(mysql): SELECT group_name, phpbb_user_group.group_id FROM phpbb_user_group, phpbb_groups WHERE phpbb_user_group.group_id = phpbb_groups.group_id AND phpbb_user_group.user_id = 408 ORDER BY group_name ASC
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
(mysql): SELECT x_gallery_images.* FROM x_gallery_images, x_gallery_cat WHERE x_gallery_images.category_id = x_gallery_cat.id AND x_gallery_cat.visible = 1 ORDER BY RAND() DESC LIMIT 0, 2
--------------------------------------------------------------------------------

--------------------------------------------------------------------------------
(mysql): SELECT id, subject FROM x_news ORDER BY date DESC LIMIT 0, 10
--------------------------------------------------------------------------------
CoH: Mr E-Man~Energy Arc~IG-2112MD~Slayer Faith~Master TimeLord~Mr E-Being
CoV: Mr E-Villain~Dark Willow~Cold Satisfaction~Mr E-Mech~Mr E-Lectric
Image

User avatar
Frost
Site Admin
Posts: 6832
Joined: Thu Jan 27, 2005 1:00 am
Location: Syracuse, NY
Contact:

Post by Frost »

Whoops, forgot to turn off debug mode.

Post Reply